ПроектыЧто НовогоСкачатьСообществоПоддержкаКомпанияВакансии
Список форумов » Основной форум GSC » Поддержка
Закрытие серверов GameSpy

1 2 3 4 5 6 7 | Следующих 10 сообщений » | Все Сообщения
Когда/Кем создано
Вопрос/ОтветНовые наверх Сортировка по убыванию
  20:03:06  17 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
ManOwaR
Linux Lover
(Администратор)

 

 
На форуме с: 01/01/2001
 

Сообщение редактировал(а):
ManOwaR
05/17/2014 20:04:34
Сообщений: 97
Закрытие серверов GameSpy

Как известно, 31 мая GameSpy собирается потушить сервера, обслуживающие сетевую игру в сотнях игр.
Очевидно это затронет и S.T.A.L.K.E.R.
Мы работаем над решнием этого вопроса, путём создания собственного сервиса, реализующего небольшое подмножество протоколов GameSpy.
Уже есть beta-версия, испытать которую мы приглашаем всех желающих игроков и операторов игровых серверов.

Для того, чтобы переключиться на использование нашего сервера, необходимо обновить библиотеки "xrGameSpy.dll" как на стороне клиента, так и на стороне сервера.

Ссылки на скачивание архивов для игр:
Зов Припяти - http://files.gsc-game.com/stk-gs-patches/COP-GameSpy.zip
Чистое Небо - http://files.gsc-game.com/stk-gs-patches/CS-GameSpy.zip
Тень Чернобыля - http://files.gsc-game.com/stk-gs-patches/SHOC-GameSpy.zip

Перед перезаписыванием DLL-ки, оригинальную рекомендуется сохранить или переименовать.
На данный момент в "Зове Припяти" не полностью работает система профилей и вообще не работает статистика.

Кроме того, патч можно установить с помощью обновления, доступного на соответствующих разделах официального сайта:
http://soc.stalker-game.ru/?page=patches
http://cs.stalker-game.ru/ru/?page=patches
http://cop.stalker-game.ru/?page=patches


Все вопросы, предложения, баги (куда же без них?) - просьба писать в этой ветке форума, или на электронную почту gamespy [собака] gsc-game.com
  21:09:25  21 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
ManOwaR
Linux Lover
(Администратор)

 

 
На форуме с: 01/01/2001
Сообщений: 97
Архивы с dll-ками обновлены. Теперь при соединении с оригинальной версией не должны появляться ошибки.
  21:27:39  21 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
xroft
(Новичок)
 
На форуме с: 05/21/2014
 

Сообщение редактировал(а):
xroft
05/21/2014 21:29:45
Сообщений: 1

---ЦИТАТА---
Архивы с dll-ками обновлены. Теперь при соединении с оригинальной версией не должны появляться ошибки.
---КОНЕЦ ЦИТАТЫ---


Здравствуйте,
на совместимость патченого клиента ТЧ и оригинального сервера не проверял, но при обновлении списка серверов пока что есть один досадный глюк: список не всегда корректно обновляется с первого раза, иногда приходится один-два раза нажимать рефреш.
При первом запросе списка серверов получаем нечто подобное:
http://rghost.ru/55522093/image.png

После рефреша инфа о серверах отображается корректно.
Также тестировал эту dll-ку с игрой версии 1.0004 , что привело к стабильному вылету при попытке запроса списка серверов. Вопрос: эта дллка несовместима с версиями игры, отличными от 1.0006 ?
Спасибо.
  23:35:19  21 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
ManOwaR
Linux Lover
(Администратор)

 

 
На форуме с: 01/01/2001
Сообщений: 97
Обновление пофиксил, должно работать.
DLL-ки только для последних версий игр.
  02:48:06  22 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
[bad]689
Профи
 

 
На форуме с: 01/28/2009
Сообщений: 633
Потестил ЧН: на сервер запущенной со старой dll-кой, видят и могут зайти игроки и со старой и с новой dll-кой,
на сервер запущенной с новой dll-кой видят и могут зайти только игроки с новой dll-кой.


Потестил ЗП: с новой dll-кой сервер запустился, но игроки со старой dll-кой его в списке как и в ЧН не видят, а игроки с новой dll-кой получают сообщение "неверный емайл" http://sc.uploads.ru/8hG67.jpg
пробовал несколько раз, не знаю может поможет если завести новый профиль?
  16:35:53  22 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
[bad]689
Профи
 

 
На форуме с: 01/28/2009
Сообщений: 633
Скажите, а вы планируете делать патчи для игры или только сделаете свой эмулятор gamespy?
  18:42:14  22 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
ManOwaR
Linux Lover
(Администратор)

 

 
На форуме с: 01/01/2001
Сообщений: 97
Скоро будет небольшой патч для рендера, для исправления некоторых интересных эффектов на очень быстрых и новых видеокартах наподобие Radeon R9 200x
  18:43:59  22 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
ManOwaR
Linux Lover
(Администратор)

 

 
На форуме с: 01/01/2001
Сообщений: 97

---ЦИТАТА---
а игроки с новой dll-кой получают сообщение "неверный емайл"
---КОНЕЦ ЦИТАТЫ---

Это нормальное поведение, новый сервер не имеет доступа к базе данных GameSpy, поэтому нужно создать новый профиль.
  04:53:00  23 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
Vojlok
Профи
 

 
На форуме с: 10/28/2009
Сообщений: 274

---ЦИТАТА---
новый сервер не имеет доступа к базе данных GameSpy, поэтому нужно создать новый профиль.
---КОНЕЦ ЦИТАТЫ---


Например, тот же самый. С тем же пасом и логином.
  06:08:35  23 Мая 2014
авторe-mailОтветить URL сообщенияНаверх
[bad]689
Профи
 

 
На форуме с: 01/28/2009
Сообщений: 633

---ЦИТАТА---
новый сервер не имеет доступа к базе данных GameSpy, поэтому нужно создать новый профиль.
Например, тот же самый. С тем же пасом и логином.
---КОНЕЦ ЦИТАТЫ---



Создать где? я через игру пробовал не получилось, до этого я регистрировался тут https://login.gamespy.com/
Если у кого получилось напишите.
 
Каждое слово должно быть не менее 3 букв.
Искать:    
Условия поиска:    - пробелы как AND    - пробелы как OR   
 
Список форумов » Основной форум GSC » Поддержка
 

Все даты в формате День-Месяц-Год.


 
Наверх

Copyright © 1995-2021 GSC Game World. Все права защищены.
Этот сайт лучше всего просматривать в Internet Explorer 4.xx и выше, с поддержкой Javascript
При возникновении проблем обращайтесь к вебмастеру.
Продукты Opera Software не поддерживаются.
При возникновении ошибок в работе сайтов с использованием продуктов Opera Software обращайтесь
в службу поддержки Opera Software.